AIX

I purchased an IBM B-50 from ebay.
When it arrived, I followed the standard practice at Collation and:
	-attached it's console to the lantronix terminal server
	-added the console port and its IP address to DNS

Its standard at Collation to install servers and workstations using
a network install. We do network installs of Solaris via jumpstart,
and linux via kickstart, but unfortunately, it seems that I need
something called NIM to install it, and NIM has to run on an AIX box.
Since this is the first AIX box, I'm going to have to do it manually.

Try to buy a copy of AIX 5.2.... see my other rant on this.

Finally, get AIX 5.2. Put cdrom #1 in the drive and boot the machine.
Press the "1" key or the "5" key after seeing the keyboard test on
the console. "5" causes the machine to boot off the cdrom.

At this point I realized that there was no hard drive in the machine...
Ok, so I add a hard drive - externally - because the proprietary 
hot swap bay is $250... Ouch.

Reboot the machine from the cdrom. Indicate that I want english
and I want to install on the hard disk and I want this tty to be
the console.

Installation proceeds, then the system reboots. I get the Console
Login prompt, but I can't login. Its like the  key is not
being accepted....
Try all sorts of terminal emulation programs - minicom, hyperterminal,
try connecting directly and throught he terminal server - same result.

Eventually, I booted off the cdrom in Repair mode, and used smitty
to enable dhcp on the network interface. On reboot, the machine
gets and address and I can successfully telnet into the machine.

+++Talked to an AIX guru friend of mine (Thanks Jabbar) and he says that the
machine is probably expecting to talk to an IBM 3151 terminal.

Added the NIS server, asterix, and its IP address to /etc/hosts, then
used "mkclient -S asterix" to configure NIS.
Started ypbind.

I used smitty to umount and delete /home, but left the mount point.

Used smitty to start automountd, but regardless of what
I did, I couldn't get it to use the NIS auto.master and auto.home tables.

Eventually, I just configured the /etc/auto_master and /etc/auto_home
but still no joy - its almost like automounter is just totally broken
on AIX. Even tried using the /usr/samples/nfs/auto_master file as a template.
Tried restarting automountd using  "stopsrc automountd" and
"startsrc automountd". It still doesn't work. Try rebooting.  automount
doesn't even start.

+++Jabbar says that the automounter on aix is just broken - don't use it.

Try "ypcat -k auto.master" - it says domainname isn't set
Where the hell are the error messages?
+++Jabbar says to use "errrpt -a"
Why isn't the domainname set on reboot?
Where the hell is the console terminal type set?

Periodically, ypbind (which does seem to know the NIS domainname) starts
claiming that the NIS server is not responding. Reboot the machine -
Now it works. Thats just ugly. 

Gave up on automountd. Disabled it with smitty and removed all the /etc/auto*
files. Used smitty to mount/home via nfs from majestix.
Of course on reboot, it wasn't mounted....

Try to get /home to be persistent. Use smitty 
                ->System Storage Management (Physical and Logical)
                ->File Systems
                ->Add/Change/Show/Delete File systems
                ->NFS

Wait! whats this! NIS settings....
                ->NIS
                ->change NIS domainname!

Ok, I don't know why the AIX people put the NIS settings under NFS,
but at least I've found them now.

Download ssh from www.bullfreeware.com
Run the .exe file which appears to be a self-extracting archive
containing a .bff file.
Tried to use "smitty install_latest" to install the bff file - it fails
when I press F4 to list the software in the directory. Tried using "."
as well as the fully qualified path - doesn't work.

Here is the error message:
----
1800-106 An error occurred
geninstall:  The specified device
/home/abarclay/src/aix/
is not a valid device or file.
----

Run "man -k install" - fails. Run "catman -w", then re-run "man -k install"
Tried installp - nope... looking for /dev/fd.....
Dammit, its the f4 thats failing to make a list of the available
software... why would it fail. in desperation, copy the bff file to
/tmp and change to that directory and re-run the smitty install_latest
Now it works! Thats just stupid.

Create the host keys using ssh_keygen -t rsa and ssh_keygen -t rsa1
and ssh_keygen -t dsa
Created the sshd priv sep user. Apparently, can't use /bin/false as a shell
for the user - have to use a real shell....
Had to use "sshd" as the pgroup, not the gidNumber.... Thats unusual.
Had to create /var/empty and /var/empty/sshd before create user
Finally, sshd started.

Now, we need to figure out how to get it to start on system reboot.
	
The ypbind is just really flaky. It keeps saying that the NIS server is
not responding, AND when that happens, all network access seems to just
die. Ping doesn't even work - Not even by IP address! Finally created a
yp server on the same subnet so the ypbind could broadcast to find the
server and now its perfectly happy.

Tried to download the latest critical patches for AIX following instructions
from Bruce Spencer's newsletter.
The fucking applet doesn't work on linux and the ftp from the command line
keeps throwing connection resets. I'll try later from Windows.

When I try to scp to the AIX machine, it reports "scp not found"
I know that ssh is trying to run scp, but it should know to look in
/usr/local/bin.... create a link from /usr/local/bin/scp to /usr/bin/scp
and now it works.

Need to install lsof. bullfreeware doesn't have it pre-packaged, so I
decide to compile it. Download the gcc package from bullfreeware and run it
to extract the bff file.  Copy the bff file to /tmp and it runs out of
space. Have to use smitty to bump up the size of /tmp to 400 meg.
Re-try the install. Hmmmm, for some reason it doesn't see the gcc software.
It only seems to see the ssh. Ah, it seems that smitty creates a .toc
file and doesn't bother checking to see if there is new software there -
very efficient and very annoying.  Remove the .toc file and re-try the install
Now it works.
Also download and install sudo using the same procedure - don't forget to
remvoe the .toc file.

Used smitty to increase size of /usr to 900 meg
Try to build lsof
$ ./Configure aixgcc
$ make
	-failed
Gave up on building it - found a binary
Fri Jun  6 11:01:44 PDT 2003